Mac Frust am Nachmittag – smb/cifs-Mount funktioniert nach OS-Upgrade nicht mehr

Mal wieder ein Tipp, der dem ein oder anderen vielleicht ein bisschen Zeit und Frust erspart. Ich hab heute einen Mac eines Kollegen “runderneuert” und neben Festplattentausch auch von Tiger auf Snow Leopard gebracht.

Grundsätzlich keine große Sache. Snow Leopard blank auf der neuen Festplatte installiert, Migrationsassisten gestartet und persönliche Daten rüberkopiert. Dabei bin ich der Versuchung erlegen, auch die Netzwerkeinstellungen mit umzuziehen, da der Kollege einige “Umgebungen” definiert hat, und ich mir und ihm die Neueinrichtung ersparen wollte.

Nach dem Umzug hat auch alles geklappt… ja leider bis auf das Verbinden von smb/cifs-Shares. Der Finder war über Apfel-K / “Mit Server Verbinden” nicht dazu zu bewegen, die Shares zu mounten. Das Verbindungsfenster popte kurz auf und verschwand dann sofort wieder ohne dass irgendeine Fehlermeldung erschien (oder was anderes passierte). Das Verbinden über das Durchsuchen der “Netzwerkumgebung” funktionierte problemlos, und andere Shares (ftp, webDAV) funktionierten ebenfalls.

Kurz vor dem Aufgeben (und der offenbar unvermeidlichen Neuinstallation) habe ich dann doch einen Blick in die Konsole geworfen und den Übeltäter identifiziert. Thursby’s DAVE! Auf Tiger war auf dem Laptop noch der kleine Helfer installiert, auf Snow Leopard hab ich mir das geschenkt… Doch offensichtlich hat die Migration der Netzwerkumgebung auch die entsprechende Erweiterung mit umgezogen sodass MacOS nicht mehr den eingebauten cifs Client aufrief, sondern den nicht vorhandenen Client von Thursby.

Erst ein runterladen der neuesten DAVE-Version mit anschließender Installation und Deinstallation hat die Sache wieder repariert….