[Basteltipp] Fritz!Box hinter SpeedPort hybrid (mit VoIP)

Ich hab vor einiger Zeit den Umstieg auf “Telekom Magenta hybrid” gewagt. Nach einigen Anlaufschwierigkeiten bin ich inzwischen mit der Internetanbindung sehr zufrieden. Die Anbindung ist schnell und ich habe bisher subjektiv noch keine Einschränkung durch die  nur fallweise Zuschaltung von LTE bemerkt. Auch eine Drosselung findet wohl nicht statt… Immerhin habe ich im Juli gut 510GB und im August knapp 600GB Daten übertragen.

Problem ist und bleibt der SpeedPort hybrid. Der tut zwar netztechnisch was er soll, ist weder von der Oberfläche und schon gar nicht von den Optionen her auf Augenhöhe mit der FritzBox. Dazu kommt noch, dass ich keine Lust habe, mein Netzwerk umzuorganisieren und meine FritzFon Telefone und DECT-Steckdosen weiter benutzen will. Es bleibt mir also nichts anderes übrig, als meine FritzBox 7490 hinter den SpeedPort zu packen. Hier meine Konfiguration die – sogar inkl. VoIP bisher tadellos funktioniert.

Hinweise:

  1. Die FritzBox muss im Experten-Modus sein, um einige der hier beschriebenen Einstellungen durchführen zu können…
  2. Bisher muss man bei untenstehender Konfiguration auf IPv6 verzichten.
  3. MyFritz.net funktioniert nicht, da die Fritz!Box die private IP-Adresse an der SpeedPort meldet.
  4. Die Portfreigabe auf UPnP-Basis funktioniert ebenfalls nicht, da die UPnP natürlich nicht von der FritzBox an den SpeedPort weitergegeben werden (bzw. dieser kein UPnP versteht).
  5. Benötigte Ports müssen auf beiden Seiten freigeschaltet werden, da der SpeedPort keinen “Exposed-Host”-Modus kennt.

Netzwerkkonfiguration

Die FritzBox war ursprünglich per DSL angeschlossen. Das hat sich durch den SpeedPort hybrid geändert. Der SpeedPort stellt die Internetverbindung her und die FritzBox ist bei mir als einziger Client direkt am SpeedPort angeschlossen. Die FritzBox habe ich hierfür unter Internet > Zugangsdaten auf “Vorhandener Zugang über LAN” eingestellt und über den LAN-Port 1 mit dem SpeedPort verbunden. Es entsteht quasi eine DMZ, zwischen SpeedPort und Fritz!Box. Netzwerk-Puristen werden hier zwar vor einem sog. Double-NAT warnen, bei mir hatte es aber bisher (gefühlt) keine Auswirkungen auf die Leistung der Anbindung. Die SpeedPort ist dann unter 192.168.2.1 und die FritzBox unter fritz.box bzw. der ursprünglichen IP erreichbar.

Wer kein Double-NAT aufbauen will kann sich an der Anleitung von Matthias Schulz (auf der dieser Post hier basiert) orientieren.

Für meine Belange habe ich zunächst beim SpeedPort  (Internet > Portfreischaltung) die (TCP-) Ports 80, 443 und 8000-9000 für die FritzBox und diverse Weboberflächen im Heimnetz und die (TCP-) Ports 5000-5001 und 32400 für meine Synology und Plex freigeschaltet. Zudem die (UDP-) Ports 53,500 und 4500 für VPN und VNC. (Zur Telefonie kommen wir später).

VoIP Telefonie

Kommen wir zu einem Punkt, der bei mir viel Frustration ausgelöst und eine Menge Kopfzerbrechen verursacht hat. Der VoIP-Telefonie.

Am Anfang war ich der naiven Meinung, dass ich hier an der FritzBox nichts ändern muss, sondern auch nach dem Umbau des Netzwerks VoIP einfach weiter funktioniert. Die ersten zwei Minuten war das auch so. Ich konnte ausgehend und eingehend Telefonieren. Nach den zwei Minuten war allerdings Schluss mit der Freude. Eingehende Telefonate kamen einfach nicht mehr durch. Und nach ein paar weiteren Minuten funktionierten auch ausgehende Gespräche nicht mehr.

Nach einem versenkten Tag hab ich dann als Work-Around die Nummer einfach im SpeedPort konfiguriert und die Fritz!Box über den analogen Port angeschlossen. Das funktioniert bei einer Nummer, spätestens bei der zweiten ist dann aber Schluss. Daher habe ich mich nochmals mit dem Thema beschäftigt und habe dann eine Lösung gefunden, die jetzt seit gut zwei Wochen funktioniert. (Ausgehende von www.matthias-schulz.de und einem Haufen Google-Anfragen nach einzelnen Konfigurations-Optionen wie z.B. “REGISTER-fetch”).

  1. Port-Freigaben an der SpeedPortAn der SpeedPort (Internet > Portfreischaltung) müssen für die VoIP Telefonie einige Ports zur FritzBox weitergeleitet werden. Das sind 3478, 3479, 5004, 5070, 5080, 30000-31000 und 40000-41000 (jeweils UDP!).
  2. Beschränkung der VoIP-Ports auf DSLVoIP über LTE macht zum Teil Probleme, daher muss die SpeedPort dazu gebracht werden die VoIP-Ports immer über DSL zu leiten (Internet > Internetverbindung > LTE deaktivieren oder Ausnahme hinzufügen) dort für die Ports 3478, 3479, 5004 und 5060 über “Datenverkehr zu festem Zielport” entsprechend einrichten

  3. Einstellungen auf der FritzBox

Hier liegen ebenfalls einige Stolperfallen und Fallstricke, die es zu umschiffen gilt:

  • Vorbereitend muss (zwingend) eine t-online-Mailadresse angelegt werden (falls noch nicht geschehen). Die Anmeldung mit der T-Online Nummer (50xxxxxxxxxxx) und dem entsprechenden Passwort hat bei mir nicht funktioniert. (http://kundencenter.telekom.de > Dienste & Abos > E-Mail > E-Mail-Center starten).
  • Zunächst müssen die Rufnummern als “Anderer Anbieter” eingerichtet werden. Die Einrichtung als Telekom-Rufnummern hilft hier nichts.Als Rufnummer für die Anmeldung muss die Rufnummer mit Vorwahl eingetragen werden, für die interne Rufnummer empfiehlt AVM die Rufnummer ohne Ortsvorwahl.
  • In der Konfiguration weiter unten dann die T-Online-Mail-Adresse (nicht die T-Online Nummer) und das entsprechende Passwort eingeben. Registrar und Proxy ist “tel.t-online.de”.Jetzt kann die Einrichtung – für’s erste – gespeichert werden. Die Überprüfung der Rufnummer scheint erstmal zu funktionieren und es sollte eine entsprechende Bestätigung der FritzBox erscheinen.
  • Das war es aber leider noch nicht! Jetzt kommt der Teil, ohne den die Rufnummer innerhalb weniger Minuten wieder nicht erreichbar sein wird!
    Nach dem erneuten Aufrufen der Einstellungen erscheinen jetzt nämlich weitere Optionen, die für das Gelingen wichtig sind!
  • Also nach dem Speichern der Rufnummer diese nochmals bearbeiten. Zunächst muss in den Einstellungen der STUN-Server “stun.t-online.de” nachgetragen werden. 
  • Weiter unten wird unter “Suffix für Internetrufnummern” die “0*49” eingetragen. Ist zwar nur ein Detail, aber ohne diese Einstellung, findet keine korrekte Zuordnung der Anrufern zu den Einträgen im Telefonbuch statt. Auf den Mobilteilen erscheint dann nur die Rufnummer des Anrufers in der Form “4983721234567”.
  • Kein Detail, sondern unbedingt notwendig ist der Haken bei “Der Anbieter unterstützt kein REGISTER-fetch”. Ich weiss nicht, was das genau bedeutet, aber ohne diese Einstellung bleibt die Rufnummer eingehend nur für einige Minuten erreichbar.
  • Unter Telefonie > Eigene Rufnummern > Anschlusseinstellungen habe ich ganz unten noch die Option “Portweiterleitung des Internet-Routers für Telefonie aktiv halten” aktiviert und auf 30sek gestellt. Ob das eine Auswirkung hat oder nur Esoterik ist, kann ich aktuell nicht sagen, schien mir aber logisch.

Das sollte es gewesen sein 😉